Application does not Launch with White

Jun 24, 2009 at 7:00 PM

Something weird is going on. I have an application that has a splash screen followed by a main window (teh splash screen has an Automation id). When I launch the application manually, the splash screen appears, does its thing and then the main window appears.

When I do the same with white - the splash screen appears and the application hangs there. Eventually, it times out and my automated test fails.


<font size="2">

Application application =



Even putting a break point here doesnt help. It just doesnt open the next main window to continue.

I even tried to sleep for 10 seconds. But doesnt work.

Any thoughts on what I am doing wrong?<font size="2">




Jun 24, 2009 at 7:44 PM

Interestingly even <font size="2" color="#2b91af"><font size="2" color="#2b91af">


</font></font><font size="2" color="#2b91af">



p = Process.Start(applicationPath);


is hanging.


Jun 24, 2009 at 8:05 PM

One more thing I must mention is that the application is created using ThinInstall.

Mar 25, 2010 at 12:43 PM

I'm having the exact same issue.  I've seen a few threads on here and either noone has solved it or noone is posting their solutions back to the group.  Anyone solved the splash screen issue yet?