Jun 3, 2009 at 11:43 AM

I've been working with version 0.17, today I downloaded the latest version and update my project to this new assemblies.

But when I do this test that was working, when the application executes the line application.WaitWhileBusy() the error is returned. What could it be?




        public void ApplicationDeploymentTest()
            // Launch application
            Application application = Application.Launch(ShellApplication.ApplicationInfo());
            Assert.IsNotNull(application, "Application object is null!");

<font size="2">




Test method Primavera.Express.Shell.Tests.Fixtures.DeploymentFixure.ApplicationDeploymentTest threw exception:  System.TypeLoadException: Method 'PreProcess' in type 'Core.Interceptors.FocusInterceptor' from assembly 'White.Core, Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation..

Jun 5, 2009 at 2:11 PM

how you change the reference in the test to new version?

Jun 5, 2009 at 2:21 PM

I changed from Core.Dll to White.Core.Dll.

But mislead any problem with config files I created a new test project on Vs2008, and the problem still happens. Only when I create a new empty project (not a test project) the application worked.

I hope that this can help, because I eager to try the new functions about Silverlight.

Jun 9, 2009 at 11:59 AM
Edited Jun 9, 2009 at 12:02 PM

After downloading the code. I rebuild all on my machine and pointed to the assemblie White.Core.Dll of my machine. And worked.

Thanks for your time.

 p.s. One more thing the assembly compiled on my machine have a slight different size: Passed from 176Kb to 224Kb!!!

Aug 12, 2011 at 9:11 AM
Edited Aug 12, 2011 at 9:22 AM

Hi all,

I have the same problem when trying to update from 0.20 to 0.21.  My AUT starts, but the first call to the main window

m_Application.GetWindow(SearchCriteria.ByText("MyMainWindow"), InitializeOption.NoCache);

throws an exception:

System.TypeLoadException : The method "PreProcess" in Type "White.Core.Interceptors.FocusInterceptor" assembly "White.Core, Version=, Culture=neutral, PublicKeyToken=2672efbf3e161801" has no implementation.
bei White.Core.Configuration.CoreAppXmlConfiguration..ctor()
bei White.Core.Configuration.CoreAppXmlConfiguration.get_Instance()
bei White.Core.Constants.get_BusyMessage()
bei White.Core.Factory.WindowFactory.CreateWindow(SearchCriteria searchCriteria, Process process, InitializeOption option, WindowSession windowSession)
bei White.Core.Application.GetWindow(SearchCriteria searchCriteria, InitializeOption initializeOption)

I have tried on Windwos 7 x64 and on Windwos XP SP3 x86, but without success. I also tried to compile the source code, it didn't work for me.

Any help is appreciated.




Aug 19, 2011 at 3:22 PM
Edited Aug 19, 2011 at 3:23 PM

Nobody any idea?




Aug 29, 2011 at 11:20 AM

I fixed it. It was the newer Castle version that White uses, its different from ours. With redirecting in app.config and pointing to the right assembly it works.