64 bit Windows 7, .NET4, WPF TreeControl...can it work?

Aug 20, 2011 at 10:38 PM

I'm working on a project where a couple of preliminary White tests had been written. They work OK for me on a Windows XP machine. When I try to run then on my laptop however (which has 64 bit Windows 7 installed) things don't all work for me.

Specifically the part that used to snag hold of a WPF tree and expand nodes thus:

            Tree fileTree = window.Get<White.Core.UIItems.TreeItems.Tree>("FileTree");
            White.Core.UIItems.TreeItems.TreeNode rootNode = fileTree.Nodes[0];
            rootNode.Expand(); // pop open the "My Computer" node

In debugging, fileTree finds its mark, and rootNode is, subsequently, definitely pointing at the root node. But the Expand() method refuses to do anything. I've tried it and a few other methods (Click(), DoubleClick()) under debug conditions and nothing obviously goes wrong...it just doesn't work.

Looking through past discussions I see similar topics, and mention of 64 bit platforms as probably the problem. However I also saw that v0.2.1 should address this -- but despite upgrading to that the problem remains. I had been typically running the test via nunit-console and saw the advice to run as nunit-console-x86 but that was also to no avail. The application under test is was building as "Any CPU" as was the test project -- I've tried both with x86 explicitly as the target. Still with no improvement.

So, my questions -- could/should this work? Is there something I'm missing? Any suggestions on how I can probe deeper to figure out the problem (I'm returning to coding after 4 years hands off so I'm a bit slow, and C# is new to me, so any hints gratefully received.)

Thanks in advance.

Jon